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Name of the Lab./facility C Programming Lab 

 

Purpose 
A prime number is a number that is divisible 
only by two numbers itself and one. The factor of 
a number is a number that can divide it. 

 

 
Scope 

In our program, we will check dividing the number 
by each number smaller than that number. If any 
number smaller than the given number divides it 
then it is not Prime number. Otherwise, it is a 

prime number. 

Responsibility Faculty In charge, HOD 

 
CHECK WHETHER THE GIVEN NUMBER IS PRIME OR NOT 

 

PROCEDURE: 
 

 Open the Turbo C and start the program. 

 Declare the variables i, n, flag as an integer data type. 

 Get any positive number. 

 Set the flag value is equal to one using the code  

          for (i=2; i<=n\2; i++) { 

          if(n%2==0) {flag==1; break;}} 

  if the input value is equal to 1 display it’s not a prime number and nor 

composite.   

 Check the flag value, if it’s equal to 0, display it’s a prime number 

otherwise it’s not a prime number. 

 Stop the program. 

 
RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility C Programming Lab 

 

Purpose 
 Fahrenheit and Celsius are the scales most often 
used for reporting room, weather, and water 
temperatures. The Fahrenheit scale is used in the 
United States, while the Celsius scale is used 
worldwide. 

 

 
Scope 

To Understand how to The formula for converting 
Fahrenheit to Celsius is C = 5/9(F-32). Fahrenheit 
and Celsius are the same at -40°. At ordinary 

temperatures, Fahrenheit is a larger number than 
Celsius. For example, body temperature is 98.6 °F 
or 37 °C. 

 

Responsibility Faculty In charge, HOD 

 
C PROGRAM TO DO TEMPERATURE CONVERSION. 

 

 

PROCEDURE: 
 

 Open the Turbo C and start the program. 

 Declare the variable Celsius & Fahrenheit as a float data type. 

 Get the Celsius value. 

 Calculate the Fahrenheit using the formula  

fahrenheit = (celsius * 9 / 5) + 32; 

 Display the Fahrenheit values in output screen. 

 Stop the program. 

 
RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 

 

 

 
 
 
 
 

https://www.thoughtco.com/definition-of-celsius-temperature-scale-605837
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Name of the Lab./facility  C Programming Lab 

 

Purpose 
 To train the students Solve quadratic equations using 

the Quadratic Formula 

 

 
Scope 

We have already seen how to solve a formula for a 
specific variable ‘in general’, so that we would do 
the algebraic steps only once, and then use the 

new formula to find the value of the specific 
variable.  

Responsibility Faculty In charge, HOD 

 

SOLVE THE QUADRATIC EQUATION USING IF STATEMENT 

 

PROCEDURE: 

 Declare the variables a, b, c, r1, r2, d as a float data type. 

 Get the A, B, C value and calculate the d value using the formula  
                                       d=b*b-4*a*c; 

 If d value is equal to 0 we put zero to ‘x’. Otherwise check (d<0) if it’s true we 
put x=1 otherwise x=2. 

 check x value using switch statement if ‘x’ is equal to ‘0’, we display “ROOTS 
ARE REAL AND EQUAL” and calculate r1 & r2 value using the formula  

r1=-b/ (2*a); 
r2=r1; 

 if ‘x’ is equal to ‘1’, we display “ROOTS ARE IMAGINARY” and calculate r1 & 
r2 value using the formula  

r1=-b/(2*a); 
r2=sqrt(abs(d)/(2*a)); 

 if ‘x’ is equal to ‘2’, we display “ROOTS ARE REAL AND   UNEQUAL” and 
calculate r1 & r2 value using the formula  

r1=(-b+sqrt(d)/(2*a)); 
r2=(-b-sqrt(d)/(2*a)); 

 Display the r1 and r2 values  

 Stop the program. 

 
RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility C Programming Lab 

 

Purpose 
The Fibonacci sequence is a sequence where the 
next term is the sum of the previous two terms. The 
first two terms of the Fibonacci sequence are 0 
followed by 1. 

 

 
Scope 

 

To Understand to use the numbers in the 
Fibonacci Sequence don't equate to a specific 
formula, however, the numbers tend to have 

certain relationships with each other. Each 
number is equal to the sum of the preceding two 
numbers. For example, 0, 1, 1, 2, 3, 5, 8, 13, 21, 
34, 55, 89, 144, 233, 377. 

Responsibility Faculty In charge, HOD 

 

C PROGRAM FOR GENERATE A FIBONACCI SERIES 

 

 

PROCEDURE: 

 Declare the variables t1, t2, nextTerm, n as an integer data type. 

 Get the positive number. 

 Calculate the Fibonacci Series using the following coding 
         nextTerm = t1 + t2; 
         while (nextTerm <= n)  
            { 

              printf("%d, ", nextTerm); 
              t1 = t2; 
              t2 = nextTerm; 
              nextTerm = t1 + t2; 
           } 

  Display the Fibonacci Series in output screen 
 

 RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility C Programming Lab 

 

Purpose 
To train the students in for Create The transpose of a 
matrix is a new matrix that is obtained by 
exchanging the rows and columns. 

 

 
Scope 

 In this program, the user is asked to enter the 

number of rows r and columns c. Their values 

should be less than 10 in this program. 
Then, the user is asked to enter the elements of the 

matrix (of order r*c). 

 

Responsibility Faculty In charge, HOD 

 

FIND THE TRANSPOSE OF A GIVEN MATRIX 

 

 

PROCEDURE: 

 Declare the variable r, c, i, j and arrays a [10][10],transpose[10][10] as a 

integer data type. 

 Get the Row(r) and Column(c) value. 

 Get the matrix elements a[i][j] one by one using for loop. 

 Display the matrix elements a[i][j] one by one using for loop. 

 Calculate the Transpose of Matrix the following steps  

            for (i = 0; i < r; ++i) 
            for (j = 0; j < c; ++j)    { 
            transpose[j][i] = a[i][j]; } 

 Display the Transpose of matrix elements transpose[i][j] one by one using for 

loop. 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility C Programming Lab 

 
Purpose 

To multiply two matrices, the number of columns of 
the first matrix should be equal to the number of rows 
of the second matrix. 

 

 

Scope 

 

Two matrices can be multiplied only when they are 

compatible, which means for the multiplication of 
matrices to exist the number of columns in the first 
matrix should be equal to the number of rows in the 

second matrix, in the above case 'n'. If A is a matrix 

of order m×n and B is a matrix of order n×p, then the 
order of the product of matrices is m×p. 

Responsibility Faculty In charge, HOD 

 

C PROGRAM TO MULTIPLY TWO GIVEN MATRICES 

 

PROCEDURE: 

 Declare the variable i,j,r1,r2,c1,c2,k and arrays a[10][10],b[10][10],c[10][10]  as 
a integer data type. 

 Get the Row (r1) and Column(c1) value of matrix A. 

 Get the Row (r2) and Column(c2) value of matrix B. 

 Get the matrix elements a[i][j] &b[i][j]  one by one using for loop. 

 Performing the Matrix multiplication using the following steps  
                           for(i=1;i<=r1;i++){ 
                           for(j=1;j<=c1;j++){ 
                           c[i][j]=0; 

                           for(k=1;k<=c2;k++){ 
                          c[i][j]=c[i][j]+(a[i][k]*b[k][j]); 
                           }}} 

  Display the matrix elements a[i][j], b[i][j] and c[i][j] one by one using for loop. 
 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility C Programming Lab 

 

Purpose 
 

To train the students in for write a c function to 
check if it is palindrome or not. 

 

 
Scope 

 
A string is said to be palindrome if reverse of the 
string is same as string. For example, “abba” is 

palindrome, but “abbc” is not palindrome. 

 

Responsibility Faculty In charge, HOD 

 

CHECK WHETHER THE GIVEN STRING IS PALINDROME OR NOT 

 
 

PROCEDURE: 
 

 Declare the variable strsrc[SIZE], strtem[SIZE] as a char data type. 

 Get the String value using gets() string function. 

 Copy the String value from ‘strsrc’ to ‘strtem’ using below step. 
             strcpy(strtem,strsrc); 

 Reverse the String value using strrev(strtem) string function. 

 Compare two String value using strcmp(strsrc,strtem) string function.  
If the strcmp return ‘0’, display the given string is palindrome. 

 Otherwise display the given string is not a palindrome. 

 
RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility C Programming Lab 

 
Purpose 

To train the students in for write C Program to find the 
sum of series 1 + 1/2 + 1/3 + 1/4 + … + 1/N. 

 

 
Scope 

For loop is used to compute the summation of each 
integer value. Initialize the value of ‘i’ variable to 1. 
Check the condition that the value of ‘i’ variable is less 
than or equal to the value of ‘number’ variable. If the 
condition is true, then execute the iteration of the loop 
and add the sum of series. 

 

Responsibility Faculty In charge, HOD 

 

C PROGRAM TO DISPLAY SUM OF SERIES 1 + 1/2 + 1/3 + …. + 1/N 

 

PROCEDURE: 
 

 Declare the variable number, sum = 0, i as a Double data type. 

 Get the ‘number’ value. 

 Calculate the sum of the series using the following steps  
                  for (i = 1; i <= number; i++)  { 
                       sum = sum + (1 / i); 
                  if (i == 1) 
                          printf("\n 1 +"); 
                 else if (i == number) 
                          printf(" (1 / %lf)", i); 
                 else 

                         printf(" (1 / %lf) + ", i); } 

 Display the Sum of series values in output screen. 

 
RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
To train the students in implement the Classes and 

Objects. 

 

 

Scope 

 

To Understand how to create the classes and 
objects in the java program. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR IMPLEMENTNG CLASSES AND 
OBJECTS 

 

PROCEDURE: 

 Start the Program 

 Create Class  

 Declare the Input and Output Variables 

 Create object and access the method  

 Implement it with return type and without parameter list  

 Implement it with return type and with parameter list  

 Implement the constructor by creating classes and objects 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
To train the students in implementing constructor 
and Destructor 

 

 
Scope 

 

To Understand how to call the sub functions 
using constructor and destructor. 

Responsibility Faculty In charge, HOD 

 
STANDARD OPERATING PROCEDURE FOR CONSTRUCTOR AND 

DESTRUCTOR 

 
 

PROCEDURE: 

 Start the Program  

 Declare and Initialize the input variables  

 Create the Constructors  

 Create various methods for Subclass  

 In derived class extend the previous class  

 In main class specify the values and create the object 

 Stop 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
To train the students in java to overload the 
methods 

 

 
Scope 

 

To Understand how to implement the methods by 
overloading. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR METHOD OVERLOADING 

 

 

PROCEDURE: 

 Start the Program 

  Initialize the File Pointer  

  Create the class Sum  

  Overload Sum with two parameters  

  Create int sum  

 Create another overloaded sum with two double parameters  

  In main function create the object and call the methods  

 Print the data in the file  

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
To train the students in java to implement the 
inheritance. 

 
 

Scope 

 
To Understand to perform the operations in 

inheritance 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR IMPLEMENTING INHERITANCE 

 

 

PROCEDURE: 

 Start the Program  

 Declare and Initialize the input variables  

 Create the class Bicycle  

 Create the constructor for Bicycle class.  

 Create various methods for Subclass  

 In derived class extend the previous class 

 In main class specify the values and create the object  

 Stop 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 

 
 
 
 
 



DEPARTMENT OF COMPUTER SCIENCE 

STANDARD OPERATING PROCEDURE 

 

       G.Venkataswamy Naidu College (Autonomous) 
Reaccredited with A Grade by NAAC 

Kovilpatti – 628 502. 
 

 

 
 

 

 

                                                        Department of Computer Science, GVNC, Kovilpatti 13 

 

 

Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
     To train the students to check number is whether 
prime or not. 

 

 
Scope 

 
To Understand to use of Conditional statements 

and check whether the given number is prime or 
not. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE  FOR CHECKING THE NUMBER IS 
PRIME OR NOT 

 

PROCEDURE: 

 Creates a class. All code needs to be in a class in order for the Java runtime 
engine to run it. Note that the entire class is defined within enclosing curly 
braces  

 The main () method, which is always the entry point into a Java program. It 
also is defined within curly braces. Let’s break it down: 
            public: This method is public and therefore available to anyone. 
            Static: This method can be run without having to create an instance 
of the class  
            void: This method does not return anything. 
           (String [] args): This method takes a String argument. 

 By the Scanner Method, this is used to get the values from the user. And the 
if conditional class the test expressions can be checked the statement. 

 When the looping statements are used, if the conditions are checked with the 
conditional statement and it gives positive result. 

 Finally, the compiler checks with the conditions and check whether the 
number is prime or not. 

 
RECORD TO BE MAINTAINED 
 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
To train the students in basic programming 
constructs of Java Language and to explore the 
features of Java by applying to solve problems. 
Can develop skills in implementing algorithms 
through the programming Language JAVA and 
to explore the features of JAVA by applying 
sample problems. 

 

 
Scope 

 

      To Understand and implement the functions in 

Multi-Threading 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE  FOR MULTI THREADING 

 
PROCEDURE: 
 

 Start the Program 

 Declare and Initialize the Variables  

 Create the class Multi-Threading Demo  

 Declare the method run  

 Create the class Multithreads  

 Specify number of Threads  

 In main method create the object and start  

 Stop 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
To train the students in for Create User Controls in 
interface. 

 

 
Scope 

 

To Understand to use User controls through 
interfaces. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR IMPLEMENT INTERFACE 

 

 

PROCEDURE: 

 Start the Program  

 Import the GUI packages  

 Create new frame and set sizes  

 In showeventdemo add button and listeners 

 In buttonclicklistener check whether the button is clicked  

 STOP 

 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 
Purpose 

To train the students in Java Applet 

 
 

Scope 

To Understand to Applet controls and the insertion 
of buttons and labels. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR INSETING JAVA APPLET 

 

PROCEDURE: 

 Creates a class. All code needs to be in a class in order for the Java runtime 

engine to run it. Note that the entire class is defined within enclosing curly 

braces  

 The main () method, which is always the entry point into a Java program. It 

also is defined within curly braces. Let’s break it down: 

            public: This method is public and therefore available to anyone. 

            Static: This method can be run without having to create an instance of 

the class  

            void: This method does not return anything. 

           (String [] args): This method takes a String argument. 

 Import applet  

 Import graphics  

 Add labels  

 STOP 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Programming with JAVA LAB 

 

Purpose 
To train the students in Java Packages. 

 

 
Scope 

 

To Understand the uses of Packages and implement 
use packages to avoid name conflicts, and to write a 
better maintainable code. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR JAVA PACKAGES 

 
PROCEDURE: 

 Creates a class. All code needs to be in a class in order for the Java runtime 

engine to run it. Note that the entire class is defined within enclosing curly 

braces  

 The main () method, which is always the entry point into a Java program. It 

also is defined within curly braces. Let’s break it down: 

            public: This method is public and therefore available to anyone. 

            Static: This method can be run without having to create an instance 

of the class  

            void: This method does not return anything. 

           (String [] args): This method takes a String argument. 

 Import package 

 Create Class A  

 Create Class B  

 Get output. 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 
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Name of the Lab./facility WEB PROGRAMMING LAB 

 

Purpose 
To train the students in Web Page Creation 

 

 
Scope 

 

To Understand how to Design the static web 
pages in HTML  

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR CREATING WEB PAGE FOR THE 
BOOK STORE WEBSITE 

 
PROCEDURE: 
 

 Home page: - the static home page must contain three pages  

 Top frame: - logo and college name and links to homepage, login page, 

registration page and catalogue page  

 Left frame: - at least four links for navigation which will display the 

catalogue of Respective links 

 Right frame: - the pages to links in the left frame must be loaded here 

initially it Contains the description of the website. 

 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility  Web Programming LAB 

 

Purpose 
To train the students JavaScript to validate the 
following fields of the Registration page. 

 

 

Scope 

 

To Understand how to validate the fields of login 
and registration pages JavaScript is used. 

JavaScript is programming code that can be 
inserted into HTML pages. JavaScript inserted 

into HTML pages, can be executed by all modern 
web browsers. JavaScript is mainly used for 

validating the elements in a form submitted by 
the user. This JavaScript code can react to user 
events. 

Responsibility Faculty In charge, HOD 

 
STANDARD OPERATING PROCEDURE FOR JAVASCRIPT TO VALIDATE THE 

FOLLOWING FIELDS OF THE REGISTRATION PAGE. 

 

PROCEDURE: 

 

 First Name (Name should contain alphabets and the length should not be 

less than 6 characters).  

 Password (Password should not be less than 6 characters’ length).  

 E-mail id (should not contain any invalid and must follow the standard 

pattern name@domain.com)  

 Mobile Number (Phone number should contain 10 digits only).  

 Last Name and Address (should not be Empty).  

 To validate the fields of registration page using JavaScript. 

 
RECORD TO BE MAINTAINED 
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Name of the Lab./facility Web Programming LAB 

 

Purpose 
To train the students Develop and demonstrate the 
usage of inline, internal and external style sheet 
using CSS. 

 

 
Scope 

 

To Understand how to implement the font styles 
and colors in Web Technology using HTML CSS. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR HTML CSS PAGE 

 

 

PROCEDURE: 
 

 Design a web page using CSS which includes the following:  

 Use different font styles 

 Control the repetition of image with background-repeat and no-repeat 

property 

 Define style for links as a: link, a: active, a: hover, a: visited 

 Add customized cursors for links. 

 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility Web Programming LAB 

 

Purpose 
To train the students in Develop and demonstrate 
JavaScript with POP-UP boxes and functions for the 
following problems: 

 

 

Scope 

 

To Understand to perform the operations in 
JavaScript with POP-UP boxes and functions. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR DEVELOP AND DEMONSTRATE 
JAVASCRIPT WITH POP-UP BOXES AND FUNCTIONS  

 

 

PROCEDURE: 
 

  Input: Click on Display Date button using onclick( ) function 

 Output: Display date in the textbox 

  Input: A number n obtained using prompt  

 Output: Factorial of n number using alert  

  Input: A number n obtained using prompt  

 Output: A multiplication table of numbers from 1 to 10 of n using alert  

  Input: A number n obtained using prompt and add another number using 

confirm  

 Output: Sum of the entire n numbers using alert 

 RECORD TO BE MAINTAINED 
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Name of the Lab./facility Web Programming LAB 

 

Purpose 
     To train the students to use the customized 
properties in the HTML 

 

 
Scope 

 
To Understand to an HTML page that contains a 
selection box with a list of 5 countries 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE  FOR THE CUSTOMIZED PROPERTIES 
IN THE HTML 

 

PROCEDURE: 

 Design a web page using CSS which includes the following:  

 Use different font styles 

 Control the repetition of image with background-repeat and no-repeat 

property 

 an HTML page that contains a selection box with a list of 5 countries.  

 When the user selects a country, its capital should be printed next in the 

list.  

 Add CSS to customize the properties of the font of the capital (color, bold and 

font size). 
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1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 

 



DEPARTMENT OF COMPUTER SCIENCE 

STANDARD OPERATING PROCEDURE 

 

       G.Venkataswamy Naidu College (Autonomous) 
Reaccredited with A Grade by NAAC 

Kovilpatti – 628 502. 
 

 

 
 

 

 

                                                        Department of Computer Science, GVNC, Kovilpatti 23 

 

 
 
 
 

 
 
 
 
 

Name of the Lab./facility Web Programming LAB 

 

Purpose 
To train the students to convert the number to 
Words in Java Script 

 
 

Scope 

 
      To Understand and implement HTML page 

including any required JavaScript that takes a 
number from text field in the range of 0 to 999 and 
shows it in words. It should not accept four and 

above digits, alphabets and special characters. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR CONVERSION OF NUMBERS TO 
WORDS. 

 

PROCEDURE: 
 

 Start the Program 

  An HTML page including any required JavaScript that takes a number from 

text field in the range of 0 to 999 and shows it in words.  

 It should not accept four and above digits, alphabets and special characters.  

 To convert number to words using JavaScript  

 

 RECORD TO BE MAINTAINED 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in Arithmetic Operation 
Using Textboxes and Buttons 

 

 
Scope 

 

To Understand how to get input form users and 
display results to them  

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR ARITHMETIC OPERATIONS 
 

 

PROCEDURE: 
 

 Open Visual Studio-->File Menu --->New project. 

 Choose Windows Form application. 

 Start project as Windows Forms app 9. 

 Maximize Box is set to False. 

 Start Location may be central or Windows default location as required. 

 Drag and Drop buttons, labels and text boxes from the toolbar. 

  A button accepts clicks. In this project five buttons are used, that accept 
click events and perform actions in the user interface. 

  In this project, three labels are used to display text on a form. 

  Three text boxes are used - two of which are used to get user input and 
the remaining one is for displaying the result. 

 
RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 
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2. Maintenance Record 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in Upload and Display Image 
using File Upload Control 

 

 
Scope 

 

To Understand how to upload images and 
signature form system  server ,This concept 

used in real time application(Ex:TNPSC, NTA 

NET….Etc) 

Responsibility Faculty In charge, HOD 

 
STANDARD OPERATING PROCEDURE FOR UPLOAD AND DISPLAY IMAGE 

USING FILE UPLOAD CONTROL 

 

 

PROCEDURE: 
 

 Open the Visual Studio –> Create a new empty Web application. 

 Create a New web page for display File Upload control. 

 Drag and drop File Upload control on web page along with one Button 
control from Toolbox. 

 Write server side code in button click event for upload image using File 
Upload control. 

 Create new folder “img” in solution explorer to store images. 

 
RECORD TO BE MAINTAINED 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in create an advertisement 
using Ad Rotator Control 

 

 
Scope 

 

To Understand how to upload images and 
signature form system  server ,This concept used 

in real time application(Ex: University & College 
Websites…Etc) 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR CREATE AN ADVERTISEMENT 
USING 

 AD ROTATOR CONTROL 

 

PROCEDURE: 

 Open Visual Studio –> Create a new empty web application / website. 

 Create New web page for display AdRotator control. 

 Drag and drop AdRotator Control on web page from toolbox. 

 Right click on Solution Explorer –> Add New Item –> Add New XML File in 
project for write advertisement detail. 

 Write code in xml file for advertisement. 

 Assign XML File to Advertisement File Property of AdRotator control. 
 
RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 

performed with the equipment 

2. Maintenance Record 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in display day, Month and Date 
using Calendar Control 

 

 
Scope 

 

To Understand to use calendar controls for display 
date,Month and Years,This concept used in real 
time application(Ex:College Website….Etc) 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR DISPLAY DAY, MONTH AND DATE 
USING CALENDAR CONTROL 

 

 

 

PROCEDURE: 

 Open your ASP.NET application and open the page where you are intended 
to add a calendar control 

 Simply drag-drop the control 

 Directly edit or type control in the markup i.e. aspx file (as shown in the 
syntax) 

 Here I am adding the control by drag-drop, once you add the control it will 
look like below snippet. 

 Now right-click on the control and select properties option, it will show 
property panel as below. We can see many properties will help with the 
layout, style, appearance, etc. 

 From this panel, you can do styling and event handling for the calendar 
control. Here n this example, I have marked the weekend in bold and Today’s 
date in green color. 

RECORD TO BE MAINTAINED 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in Validation Controls 

 

 

Scope 

To Understand to use Validation controls for Enter 

the details correctly in application Forms, this 
concept used in real time application (Ex: Creating  
E Mail ID Account ,Facebook Account….Etc) 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE  FOR VALIDATION CONTROL 

 

PROCEDURE: 
 Start Visual Studio. 
 Now, we need to create a website using "File" -> "New" -> "Website". 
 Now, select the ASP.NET Empty Website and click on the OK button 
 Now, add the Web form by right-clicking on the website and provide a name 

to the Web Form. 
 After the web form is created, we will design the form as shown in the 

following screenshot. 
 We will write the following code in the Validator.aspx page. 
 Now, we need to execute the web form using the F5 key and will get the 

following window form. 
 Now, check whether the validation is working correctly or not. When we 

click on the submit button, then the following error can be seen. 
 Now, check the email validation on the web form. If we write the wrong 

email-id, then the error message appears on the form. 
 Now, we need to check the password validation. If we are writing a different 

password into the password textboxes, then the error message appears on 
the web form. 

 Now, we need to check the validation of the dropdown list. If we don't select 
the country name, then the following error message appears: "plz select 
your country name". 

 
RECORD TO BE MAINTAINED 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
 

To train the students in display data in grid View 

 
 

Scope 

 
To Understand to use data in grid view for display 

data, This concept used in real time 
application(Ex:College and University Fees Details 
Applications….Etc) 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE  FOR DISPLAY DATA IN GRID VIEW 

 

 
PROCEDURE: 

 Create new project in Visual Studio 2015. 

 Go to File-> New-> Website -> Visual C#-> ASP.NET empty Website-> Entry 
Application Name-> OK. 

 Add Web form to the Website. 
Project name-> Add-> Add New Item-> Web Form-> write name ->Add. 

 HomePage.aspx (Web form) page is created. 

 Click Design Button-> Add Grid View from Toolbox. Toolbox-> Data-> Grid 
View. 

 Right Click on Grid View-> select View Code. 

 Add the namespaces, mentioned below, in the code back-end page. 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in for Create User Control with 
source 

 

 
Scope 

 

To Understand to use User controls for creating 
own login page using user name and password 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR CREATE USER CONTROL WITH 
SOURCE 

 

 

 

PROCEDURE: 

 Launch VS.Net Start-> Programs->visual studio.net30 

 Create a new project  

 Select file ->New->Project->Visual Basic->Windows Forms Control Library  

 Give name to the project “My Control Library” Press ok button. 

 Add a user control to a project 

 In the solution explorer window right click the project name (My Control 
Library) 

 Give rename to the user control “login” press ok button. 
 
RECORD TO BE MAINTAINED 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in for  Login Page using Session 
Variable 

 
 

Scope 

 
To Understand to use Session Variable  for Login 

Page, this Concept is used in Real Time 

Application(Ex:Online Exam Application Websites) 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR LOGIN PAGE USING SESSION 
VARIABLE 

 

 
 

PROCEDURE: 

 Open Visual Studio 2010. 
Then Click on "New Project"  -> "WEB" -> "ASP.NET Empty Web Application". 

 Now click on Solution Explorer. 

 Now right-click on the "Add" -> "New Item" -> "Web Form" and add the name of 
the web form and I had added 2 Web Form1.aspx and Web Form2.aspx. 

 After adding the web form the following code is added to Web Form1.aspx. 
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Name of the Lab./facility ASP.Net LAB 

 

Purpose 
To train the students in for Student Mark List using 
SQL Provider 

 

 
Scope 

 

To Understand to use  SQL Provider for Save and 
Retrieve data form Database, This concept used in 
real time application(Ex:College Website….Etc) 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR STUDENT MARK LIST USING SQL 
PROVIDER 

 

 
 

PROCEDURE: 

 First open your visual studio-->File-->New-->website-->ASP.NET Empty 
Website -->OK--Open solution Explorer-->Add New Web Form (Default.aspx). 
Now Add an Database.mdf file in your website -->Make a student table  

 Now open your Default.aspx page -->Click Source button from below-->Write 
the following Grid view layout code (html code) 

 Now click Design from the below of Default.aspx page-->you will see following 
layout 

 Now go properties of Grid view control-->Click Events-->Row command--
>write command Name-->Double click on that for generating the handler 

 Now double click on the page (or press F7) -->write the following codes 

on default.aspx.cs  

 Now Add another web form (print.aspx) -->click Source button -->and write 
Grid view layout codes (html and java script)  

 Now Double click on print.aspx page (or press F7) 

 Now Run the Application (press F5) -->Follow the following points to run the 
Grid view application perfectly,  
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Name of the Lab./facility Mobile Application Development Lab 

 

Purpose 
To train the students in create a mobile 
application Using layouts and Listeners. 

 

 
Scope 

 
To Understand How To Develop An Application 

That Uses Layout Managers And Event Listeners. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR USING LAYOUT MANAGERS AND 
EVENT LISTENERS. 

 

PROCEDURE: 

 Start the application by Click on File -> New and choose Android Application 

Project and type the application name for the project and click on the next button. 

 Create an activity by selecting blank activity and then click next. 

 A blank activity will be created and finally click finish button. 

 On clicking the finish button a new project will be created from which the java code 

and layout code can be opened. 

 Go to xml code of design change the layout to “Relative Layout” 

 Add button2 component to display result & change the following properties: 

             • Size: 36sp  
             • Text: color 

             • Center-Align  

 Add text view  component to display result & change the following properties: 

             • Size: 36sp  
             • Text: color 

             • Center-Align  

 Type the XML program in layout code and type the Java program in java file. 

 Run the project by right clicking on your project in Package Explorer window on the 

left and choose Run As => Android Application. 

 Now the application is opened in the emulator for use. 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be 

performed with the equipment 

2. Maintenance Record 

 
 
 

SEMESTER V (2022-2023) 



DEPARTMENT OF COMPUTER SCIENCE 

STANDARD OPERATING PROCEDURE 

 

       G.Venkataswamy Naidu College (Autonomous) 
Reaccredited with A Grade by NAAC 

Kovilpatti – 628 502. 
 

 

 
 

 

 

                                                        Department of Computer Science, GVNC, Kovilpatti 34 

 

Name of the Lab./facility Mobile Application Development Lab 

 

Purpose 
To train the students in create an application and 
change font color and size Using GUI 
Components. 

 

 
Scope 

 

To Understand how to develop user interface 
application. 

Responsibility Faculty In charge, HOD 

 
STANDARD OPERATING PROCEDURE FOR USING GUI COMPONENTS, FONT 

AND COLORS 

 

PROCEDURE: 

 Start the application by Click on File -> New and choose Android Application 

Project and type the application name for the project and click on the next button. 

 Create an activity by selecting blank activity and then click next. 

 A blank activity will be created and finally click finish button. 

 On clicking the finish button a new project will be created from which the java code 

and layout code can be opened. 

 Go to xml code of design change the layout to “Relative Layout” 

 Add button2 component to display result & change the following properties: 

             • Size: 36sp  
             • Text: color 

             • Center-Align  

 Add text view  component to display result & change the following properties: 

             • Size: 36sp  
             • Text: color 

             • Center-Align  

 Type the XML program in layout code and type the Java program in java file. 

 Run the project by right clicking on your project in Package Explorer window on the 

left and choose Run As => Android Application.Now the application is opened in the 

emulator for use 
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Name of the Lab./facility Mobile Application Development Lab 

 

Purpose 
To train the students in develop mobile application 
that draw a basic shapes 

 

 
Scope 

 

To Understand How To Develop An Application That 

Uses Graphic Shapes. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR DRAWS BASIC GRAPHICAL 
PRIMITIVES ON THE SCREEN 

 

 

PROCEDURE: 

 Go to res folder and select layout. Double click the main.xml file and type the code. 

  Go to project explorer and select src folder. Now select mainactivity.java file and 

type the 

code. 

  Go to xml code of design change the layout to “Relative Layout” 

 Add Textview,textview1,textview2,textview3 component & change the following 

properties:  

             • Size: 36sp . 

           •Text (Text view):Square, 

(Texview1):Rectangle,(Textview3):Circle,(Textview3):Line 

             • Center-Align . 

 Add Four Image Button component to display result & change the following 

properties: 

 Size: 36sp  

 text(Button)="Triangle"  

 text(Button)="circle" 

 text(Button)="line"       

 Run the project by right clicking on your project in Package Explorer window on the 

left and choose Run As => Android Application. 

 Now the application is opened in the emulator for use. 
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Name of the Lab./facility Mobile Application Development Lab 

 

Purpose 
 

To Train The Students In Create An Mobile 
Application Implementing Multi-Threading concept. 

 

 

Scope 

 

To Understand how to use data Thread creation by 

implementing the Runnable Interface, This concept used 

in real time application 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE FOR MULTI THREADING 

 

 

PROCEDURE: 

 Start the application by Click on File -> New and choose Android Application Project 

and type the application name for the project and click on the next button. 

 Create an activity by selecting blank activity and then click next. 

 A blank activity will be created and finally click finish button. 

 On clicking the finish button a new project will be created from which the java code 

and layout code can be opened. 

 Go to res folder and select layout. Double click the main.xml file and type the code. 

  Go to project explorer and select src folder. Now select mainactivity.java file and type 

the 

code. 

 Run the emulator before execute the application by, Windows->Virtual Device 

manager->create new emulator first time->set the properties->Launch the emulator. 

 Run the project by right clicking on your project in Package Explorer window on the 

left and choose Run As => Android Application. 

 Now the application is opened in the emulator for use. 
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Name of the Lab./facility Mobile Application Development Lab 

 

Purpose 
To train the students android program .to implement 
write and read a file to external device. 

 

 

Scope 

 

To understand how to develop an android 

application that writes data to the sd card 

Responsibility Faculty In charge, HOD 

 
STANDARD OPERATING PROCEDURE  FOR WRITES DATA TO THE SD CARD 

 

PROCEDURE: 

 

 Go to res folder and select layout. Double click the main.xml file and type the code. 

  Go to project explorer and select src folder. Now select mainactivity.java file and type 

the 

code. 

  Go to xml code of design change the layout to “Relative Layout” 

 Add Textview component & change the following properties:  

 Size: 36sp . 

 Center-Align . 

 Add Three Button component to display result & change the following properties: 

 Size: 36sp  

 text(Button)="Write a data"  

 text(Button)="Read a Data" 

 text(Button)="Clear"       

 Run the emulator before execute the application by, Windows->Virtual Device 

manager->create new emulator first time->set the properties->Launch the emulator. 

 Now the application is opened in the emulator for use. 

 
RECORD TO BE MAINTAINED 
 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 

 



DEPARTMENT OF COMPUTER SCIENCE 

STANDARD OPERATING PROCEDURE 

 

       G.Venkataswamy Naidu College (Autonomous) 
Reaccredited with A Grade by NAAC 

Kovilpatti – 628 502. 
 

 

 
 

 

 

                                                        Department of Computer Science, GVNC, Kovilpatti 38 

 

 

Name of the Lab./facility Mobile Application Development Lab 

 

Purpose 
To train the students in create a sample mobile 

application. 

 
 

Scope 

 

To Understand How To Create and design A 
Application. Uses Emulator To Run The Application. 

Responsibility Faculty In charge, HOD 

 

STANDARD OPERATING PROCEDURE  FOR  A SAMPLE MOBILE APPLICATION 

 

PROCEDURE: 
 

 Start the application by Click on File -> New and choose Android Application Project  

 Type the application name for the project and Create an activity by selecting blank 

activity. 

 A blank activity will be created and finally click finish button. 

 On clicking the finish button a new project will be created from which the java code and 

layout code can be opened. 

 Go to res folder and select layout. Double click the main.xml file and type the code. 

 Type the code for main.xml or drag and drop various components used in our program. 

  Add Textview component & change the following properties:  

 Size: 36sp . 

 Text:”HELLO WORLD” 

 Center-Align . 

 components used in the xml program   

 Save the program and Run the program 

 Output can be viewed in the android emulator 

RECORD TO BE MAINTAINED 

1. Laboratory Manual containing the experiments that can be performed 
with the equipment 

2. Maintenance Record 


